Welcome

Top Next

Begin the Introduction


Overview

Overview Previous Top Next
Fresh Diagnose is a complete and comprehensive tool for diagnosing and benchmarking your computer. It supplies many informations about both hardware and software system of your computer, its multimedia system, devices installed in it, and its resources. Also included, several benchmark tests to find out really, reliably, and exactly the capability indexes of your hardwares. It also supports printing and saving in multiple format : plain-text, html, rtf and doc.The features in this version :

Information modules
Operating System, Advanced Power Monitor, CMOS, User and Locale Info, Timezone, Shell Folders, Engines, Fonts, System Files, Workstation, Processor, Resources, Processes, Memory, Drives, Display Adapters, Keyboard, Mouse, Printers, Ports, Plug and Play, Internet Settings, Network, Winsock, Internet Explorer, Multimedia Devices, MCI, DirectX, DirectDraw, DirectSound, Interrupt Requests (IRQ's), DMA Channels, Ports I/O, Memory Resources.

Benchmark modules
Processor Benchmark, Multimedia Benchmark, Memory Benchmark, Harddisk Benchmark, CD Benchmark, Network Benchmark.
Tested under Windows 98, Windows 98 Second Edition, Windows Millenium, Windows 2000, and should work in later version of Windows.


System Requirements

System requirements Previous Top Next
Operating Systems:
Windows 95, Windows 95 OSR2, Windows 98, Windows 98 Second Edition, Windows Me, Windows NT 4.0, Windows 2000, Windows XP.

CPU:
Any x86 if only Windows was started.

RAM:
Any size if only Windows was started.


Benchmarking

Benchmarking Your System Previous Top Next
CPU BenchmarkThis benchmark performs continuous and complex calculations based on well-known Whetstone and Dhrystone algorithms. Whetstone was written by Harold Curnow in 1972, and optimised for floating point benchmark. Dhrystone, whose the first version was produced by Reinhold P. Weicker, is a sort of Whetstone without floating point and became the key standard of integer benchmark.

The benchmark produces speed ratings in terms of Millions of Whetstone Instructions Per Second (MWIPS) and Millions of Dhrystone Instructions Per Second (MDIPS). It also produces an actual speed rating in Megahertz. Bigger is better.
The results may be different for same processors with different operating systems. It can be explained by how each operating system handles and supports processor's instruction sets.
CPU Multimedia Benchmark
This benchmark performs a set of Intel SSE, SSE2, x87 and AMD 3DNow! instructions including binary and logical operations to produce a rating of 100. Bigger is better.
The results may be different for same processors with different operating systems. It can be explained by how each operating system handles and supports processor's instruction sets.
Memory Benchmark
This benchmark performs a set of memory operations (at least 100 KB) including array assignment and splitting. Integer Assignment value means index of your memory speed in handling an integer array. Integer Split value means index of your memory speed in performing an integer array splitting. Both values are similar to Real Assignment and Split. Bigger is better.
Harddisk Benchmark
This benchmark performs both read and write tests to your fixed drives. It creates a temporary file called 'sysinfo.bch' in the root directory to perform read and write test. The results are in MB/s (megabyte per second). Bigger is better
CD Benchmark
This benchmark performs a single read test to your CD drives. It will require a CD audio, CD data, VCD or DVD as a medium to find out the speed rate. We suggest an easy-to-read and non-autorun one. The result is in MB/s (megabyte per second). Bigger is better.
Network Benchmark
This benchmark performs a ping instruction and both read and write tests to a specified connection. If the selected connection is a read-only one, it will only perform a ping test. The results of read and write tests are in MB/s (megabyte per second). Bigger is better.


Distribution

Distribution Previous Top Next

You may reproduce and distribute an unlimited number of copies of FRESH DIAGNOSE ; provided that each copy shall be a true and complete copy, including all copyright and trademark notices, and shall be accompanied by a complete documentations.

FRESH DIAGNOSE may not be sold or be included in a product or package which intends to receive benefits through the inclusion of this product. FRESH DIAGNOSE may be included in any free or non-profit packages or products.

This FRESH DIAGNOSE software is the property of FRESHDEVICES CORPORATION. Any reproduction in whole or in part is strictly prohibited.


Disclaimer

Disclaimer Previous Top Next

FRESH DIAGNOSE IS PROVIDED AS IS. FRESHDEVICES CORP. will in no way be responsible, in financial or any other terms, for damages (either consequential or incidental) resulting from the use or misuse of FRESH DIAGNOSE or from following directions in this document. No warrantee as to fitness to a particular purpose is given or implied.

Because of the wide variety of hardware and software combinations available today, it is up to the user to ensure that FRESH DIAGNOSE functions well in his or her environment. The user must assume the entire risk of using FRESH DIAGNOSE.


Licensing

Licensing Previous Top Next

A. Personal License
FRESH DIAGNOSE is FREE for personal/private use only. Free registration is required if you want to use it longer than 11 days. Registration number for this version can be obtained for FREE, simply visit http://www.freshdevices.com.

B. Business License
The license associated with this product allows for free personal use only. Use on PC(s) in a corporate, educational, military or government installation is prohibited. You MUST purchase a license if you are using this software in any business, commercial, educational, military or goverment organization. This license also covers two other software published by Freshdevices.com: FreshDownload and FreshDiagnose.

1. Freshdevices Home Office License ......... USD 39 (1 computer)
2. Freshdevices Bronze License ................ USD 95 (up to 5 computers)
3. Freshdevices Silver License .................. USD 295 (up to 25 computers)
4. Freshdevices Gold License ................... USD 995 (up to 250 computers).


contact us

Bugs reports Previous Top Next

Send your comments, suggestions and bug reports for future development of FRESH DIAGNOSE to http://www.freshdevices.com/contact.html